Uploaded image for project: 'Elements Connect'
  1. Elements Connect
  2. CO-3653

Configuration tester is broken in the display tab if a field name contains ' or " or if it's translated

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: 6.0.1, 6.1.0, 6.1.5
    • Fix Version/s: 6.9.0
    • Labels:
      None
    • Environment:

      Jira 7.13.3

    • Functional components:
      Admin - Field configuration

      Description

      How to reproduce

      Two ways to reproduce this bug:

      1. Create an Elements Connect Live Text field with a single or double quotation mark. For example: "Connect's Field"
      2. Create an Elements Connect Live Text field, translate it and switch your language preferences from your profile to the translated language

      Then

      1. From Elements Connect admin
      2. Configure the field
      3. Go to the "Display tab"

      Current result

      An error in the browser console appears :

      Request URL: http://localhost:2990/jira/rest/api/2/search?jql=%22Connect%26%2339%3Bs%20field%22%20is%20not%20empty&fields=summary&maxResults=15&_=1571844045688Request Method: GETStatus Code: 400 Remote Address: [::1]:2990Referrer Policy: no-referrer-when-downgrade
      

      The configuration tester displays an empty error (see picture)

      Expected result

      No error! 

        Attachments

          Issue Links

            Customer requests

            No authorized issue linked

              Activity

                People

                Assignee:
                Unassigned Unassigned
                Reporter:
                basile.grandperret@valiantys.com Basile Grandperret
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: